import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "type(?!3\\.)\\d+\\.value(\\d+)=\\K\\d+(?=[\\s\\S]*?type3\\.value\\1=(\\d+))";
final String string = "type1.value1=60\n"
+ "type1.value2=15\n"
+ "type2.value1=50\n"
+ "type2.value2=18\n"
+ "type3.value1=72 \n"
+ "type3.value2=14";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}