const regex = /type(?!3\.)\d+\.value(\d+)=\K\d+(?=[\s\S]*?type3\.value\1=(\d+))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('type(?!3\\.)\\d+\\.value(\\d+)=\\K\\d+(?=[\\s\\S]*?type3\\.value\\1=(\\d+))', 'gm')
const str = `type1.value1=60
type1.value2=15
type2.value1=50
type2.value2=18
type3.value1=72
type3.value2=14`;
const subst = `\2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);