using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"type(?!3\.)\d+\.value(\d+)=\K\d+(?=[\s\S]*?type3\.value\1=(\d+))";
string substitution = @"\2";
string input = @"type1.value1=60
type1.value2=15
type2.value1=50
type2.value2=18
type3.value1=72
type3.value2=14";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}