#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)type(?!3\.)\d+\.value(\d+)=\K\d+(?=[\s\S]*?type3\.value\1=(\d+))"
Local $sString = "type1.value1=60" & @CRLF & _
"type1.value2=15" & @CRLF & _
"type2.value1=50" & @CRLF & _
"type2.value2=18" & @CRLF & _
"type3.value1=72 " & @CRLF & _
"type3.value2=14"
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)