re = /type(?!3\.)\d+\.value(\d+)=\K\d+(?=[\s\S]*?type3\.value\1=(\d+))/m
str = 'type1.value1=60
type1.value2=15
type2.value1=50
type2.value2=18
type3.value1=72
type3.value2=14'
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result