#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^\w+(\.[\w-]+)*@([\w-]+\.)*\w([\w-]+\.)+[\w-]+$"
Local $sString = "lqw0@xs4dys3.ugch" & @CRLF & _
"aybg6_o2u@5h3ldf2.owu" & @CRLF & _
"1qq@o9ktoel7r5i.bhe" & @CRLF & _
"bvp3wvq@p1idtm.yk" & @CRLF & _
"ppc@ebur3k8dz7x5oto.lxux" & @CRLF & _
"8nvy76@xd2mxvenu4n.hl" & @CRLF & _
"0im5l20bpre7lqce6@s8pz941v.au" & @CRLF & _
"rc@bmn4n.da" & @CRLF & _
"i6altyo3@zcvv3383f.tvhg" & @CRLF & _
"njvg@71ya.scof"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")