package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\w+(\.[\w-]+)*@([\w-]+\.)*\w([\w-]+\.)+[\w-]+$`)
var str = `lqw0@xs4dys3.ugch
aybg6_o2u@5h3ldf2.owu
1qq@o9ktoel7r5i.bhe
bvp3wvq@p1idtm.yk
ppc@ebur3k8dz7x5oto.lxux
8nvy76@xd2mxvenu4n.hl
0im5l20bpre7lqce6@s8pz941v.au
rc@bmn4n.da
i6altyo3@zcvv3383f.tvhg
njvg@71ya.scof`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}