import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\w+(\\.[\\w-]+)*@([\\w-]+\\.)*\\w([\\w-]+\\.)+[\\w-]+$";
final String string = "lqw0@xs4dys3.ugch\n"
+ "aybg6_o2u@5h3ldf2.owu\n"
+ "1qq@o9ktoel7r5i.bhe\n"
+ "bvp3wvq@p1idtm.yk\n"
+ "ppc@ebur3k8dz7x5oto.lxux\n"
+ "8nvy76@xd2mxvenu4n.hl\n"
+ "0im5l20bpre7lqce6@s8pz941v.au\n"
+ "rc@bmn4n.da\n"
+ "i6altyo3@zcvv3383f.tvhg\n"
+ "njvg@71ya.scof";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}