use strict;
my $str = 'lqw0@xs4dys3.ugch
aybg6_o2u@5h3ldf2.owu
1qq@o9ktoel7r5i.bhe
bvp3wvq@p1idtm.yk
ppc@ebur3k8dz7x5oto.lxux
8nvy76@xd2mxvenu4n.hl
0im5l20bpre7lqce6@s8pz941v.au
rc@bmn4n.da
i6altyo3@zcvv3383f.tvhg
njvg@71ya.scof';
my $regex = qr/^\w+(\.[\w-]+)*@([\w-]+\.)*\w([\w-]+\.)+[\w-]+$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}