const regex = /^\w+(\.[\w-]+)*@([\w-]+\.)*\w([\w-]+\.)+[\w-]+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\w+(\\.[\\w-]+)*@([\\w-]+\\.)*\\w([\\w-]+\\.)+[\\w-]+$', 'gm')
const str = `lqw0@xs4dys3.ugch
aybg6_o2u@5h3ldf2.owu
1qq@o9ktoel7r5i.bhe
bvp3wvq@p1idtm.yk
ppc@ebur3k8dz7x5oto.lxux
8nvy76@xd2mxvenu4n.hl
0im5l20bpre7lqce6@s8pz941v.au
rc@bmn4n.da
i6altyo3@zcvv3383f.tvhg
njvg@71ya.scof`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}