// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^\w+(\.[\w-]+)*@([\w-]+\.)*\w([\w-]+\.)+[\w-]+$").unwrap();
let string = "lqw0@xs4dys3.ugch
aybg6_o2u@5h3ldf2.owu
1qq@o9ktoel7r5i.bhe
bvp3wvq@p1idtm.yk
ppc@ebur3k8dz7x5oto.lxux
8nvy76@xd2mxvenu4n.hl
0im5l20bpre7lqce6@s8pz941v.au
rc@bmn4n.da
i6altyo3@zcvv3383f.tvhg
njvg@71ya.scof";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}