using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[\w']*\p{L}*\w[\w.]*(?:-\w+.)?";
string input = @"This is great. I am going to the mall. I will be there soon. Yes, I will. Okay. test-mouse.Seven Times
l'afdfd.
Montréal
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}