package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\w']*\p{L}*\w[\w.]*(?:-\w+.)?`)
var str = `This is great. I am going to the mall. I will be there soon. Yes, I will. Okay. test-mouse.Seven Times
l'afdfd.
Montréal
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}