// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)[\w']*\p{L}*\w[\w.]*(?:-\w+.)?").unwrap();
let string = "This is great. I am going to the mall. I will be there soon. Yes, I will. Okay. test-mouse.Seven Times
l'afdfd.
Montréal
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}