re = /[\w']*\p{L}*\w[\w.]*(?:-\w+.)?/m
str = 'This is great. I am going to the mall. I will be there soon. Yes, I will. Okay. test-mouse.Seven Times
l\'afdfd.
Montréal
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end