import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[\\w']*\\p{L}*\\w[\\w.]*(?:-\\w+.)?";
final String string = "This is great. I am going to the mall. I will be there soon. Yes, I will. Okay. test-mouse.Seven Times\n\n"
+ "l'afdfd.\n\n"
+ "Montréal\n\n\n\n\n\n\n\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}