const regex = /[\w']*\p{L}*\w[\w.]*(?:-\w+.)?/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[\\w\']*\\p{L}*\\w[\\w.]*(?:-\\w+.)?', 'gm')
const str = `This is great. I am going to the mall. I will be there soon. Yes, I will. Okay. test-mouse.Seven Times
l'afdfd.
Montréal
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}