$re = '/[\w\']*\p{L}*\w[\w.]*(?:-\w+.)?/m';
$str = 'This is great. I am going to the mall. I will be there soon. Yes, I will. Okay. test-mouse.Seven Times
l\'afdfd.
Montréal
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);