#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bwin(?:dows)?(?:\s+server)?(?:\s*(?:200[38]|201[269]))?\b"
Local $sString = "microsoft windows 2016" & @CRLF & _
"win2016" & @CRLF & _
"win2012" & @CRLF & _
"windows 2012" & @CRLF & _
"windows server 2012" & @CRLF & _
"windows server 2008 r2" & @CRLF & _
"windows server 2008" & @CRLF & _
"windows 2019" & @CRLF & _
"windows 2012 r2 std" & @CRLF & _
"win2003" & @CRLF & _
"windows server 2003" & @CRLF & _
"windows 2003"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")