package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bwin(?:dows)?(?:\s+server)?(?:\s*(?:200[38]|201[269]))?\b`)
var str = `microsoft windows 2016
win2016
win2012
windows 2012
windows server 2012
windows server 2008 r2
windows server 2008
windows 2019
windows 2012 r2 std
win2003
windows server 2003
windows 2003`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}