import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bwin(?:dows)?(?:\\s+server)?(?:\\s*(?:200[38]|201[269]))?\\b";
final String string = "microsoft windows 2016\n"
+ "win2016\n"
+ "win2012\n"
+ "windows 2012\n"
+ "windows server 2012\n"
+ "windows server 2008 r2\n"
+ "windows server 2008\n"
+ "windows 2019\n"
+ "windows 2012 r2 std\n"
+ "win2003\n"
+ "windows server 2003\n"
+ "windows 2003";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}