use strict;
my $str = 'microsoft windows 2016
win2016
win2012
windows 2012
windows server 2012
windows server 2008 r2
windows server 2008
windows 2019
windows 2012 r2 std
win2003
windows server 2003
windows 2003';
my $regex = qr/\bwin(?:dows)?(?:\s+server)?(?:\s*(?:200[38]|201[269]))?\b/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}