const regex = /\bwin(?:dows)?(?:\s+server)?(?:\s*(?:200[38]|201[269]))?\b/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\bwin(?:dows)?(?:\\s+server)?(?:\\s*(?:200[38]|201[269]))?\\b', 'gm')
const str = `microsoft windows 2016
win2016
win2012
windows 2012
windows server 2012
windows server 2008 r2
windows server 2008
windows 2019
windows 2012 r2 std
win2003
windows server 2003
windows 2003`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}