# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\bwin(?:dows)?(?:\s+server)?(?:\s*(?:200[38]|201[269]))?\b"
test_str = ("microsoft windows 2016\n"
"win2016\n"
"win2012\n"
"windows 2012\n"
"windows server 2012\n"
"windows server 2008 r2\n"
"windows server 2008\n"
"windows 2019\n"
"windows 2012 r2 std\n"
"win2003\n"
"windows server 2003\n"
"windows 2003")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.