# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/https:\/\/(int.|dev.)?example\.com(.*)/https:\/\/www.${1}example.com${2}/g;t' <<< "https://int.example.com/lmds"