const regex = new RegExp('https://(int.|dev.)?example\\.com(.*)', 'g')
const str = `https://int.example.com/lmds`;
const subst = `https://www.${1}example.com${2}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);