re = /https:\/\/(int.|dev.)?example\.com(.*)/
str = 'https://int.example.com/lmds'
subst = 'https://www.${1}example.com${2}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result