use strict;
my $str = 'https://int.example.com/lmds';
my $regex = qr`https://(int.|dev.)?example\.com(.*)`p;
my $subst = 'https://www.${1}example.com${2}';
my $result = $str =~ s`$regex`$subst`rg;
print "The result of the substitution is' $result\n";