using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"https://(int.|dev.)?example\.com(.*)";
string substitution = @"https://www.${1}example.com${2}";
string input = @"https://int.example.com/lmds";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}