using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b\d{4}\s*\d{4}\s*\d{4}\s*\d{4}\b";
string input = @"1234 1234 1234 1234aas
1234 12344321 1234
1234123443211234
1234 1234 4321 1234";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}