const regex = /\b\d{4}\s*\d{4}\s*\d{4}\s*\d{4}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\d{4}\\s*\\d{4}\\s*\\d{4}\\s*\\d{4}\\b', 'g')
const str = `1234 1234 1234 1234aas
1234 12344321 1234
1234123443211234
1234 1234 4321 1234`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}