$re = '/\b\d{4}\s*\d{4}\s*\d{4}\s*\d{4}\b/';
$str = '1234 1234 1234 1234aas
1234 12344321 1234
1234123443211234
1234 1234 4321 1234';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);