re = /\b\d{4}\s*\d{4}\s*\d{4}\s*\d{4}\b/
str = '1234 1234 1234 1234aas
1234 12344321 1234
1234123443211234
1234 1234 4321 1234'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end