// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\b\d{4}\s*\d{4}\s*\d{4}\s*\d{4}\b").unwrap();
let string = "1234 1234 1234 1234aas
1234 12344321 1234
1234123443211234
1234 1234 4321 1234";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}