import Foundation
let pattern = #"\b\d{4}\s*\d{4}\s*\d{4}\s*\d{4}\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
1234 1234 1234 1234aas
1234 12344321 1234
1234123443211234
1234 1234 4321 1234
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)