using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d)(?=((\d\d\d)+(\D|$)))";
string substitution = @"\1.";
string input = @"12 мало
лучше 123
1234 почти
12354 хорошо
стало 123456
супер 1234567";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}