const regex = new RegExp('(\\d)(?=((\\d\\d\\d)+(\\D|$)))', 'gm')
const str = `12 мало
лучше 123
1234 почти
12354 хорошо
стало 123456
супер 1234567`;
const subst = `\1.`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);