import re
regex = re.compile(r"(\d)(?=((\d\d\d)+(\D|$)))", flags=re.MULTILINE)
test_str = ("12 мало \n"
"лучше 123 \n"
"1234 почти \n"
"12354 хорошо \n"
"стало 123456 \n"
"супер 1234567")
subst = "\\1."
result = regex.sub(subst, test_str)
if result:
print(result)