$re = '/(\d)(?=((\d\d\d)+(\D|$)))/m';
$str = '12 мало
лучше 123
1234 почти
12354 хорошо
стало 123456
супер 1234567';
$subst = "\1.";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;