use strict;
my $str = '12 мало
лучше 123
1234 почти
12354 хорошо
стало 123456
супер 1234567';
my $regex = qr/(\d)(?=((\d\d\d)+(\D|$)))/mp;
my $subst = '\\1.';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";