import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d)(?=((\\d\\d\\d)+(\\D|$)))";
final String string = "12 мало \n"
+ "лучше 123 \n"
+ "1234 почти \n"
+ "12354 хорошо \n"
+ "стало 123456 \n"
+ "супер 1234567";
final String subst = "\\1.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}