#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(http[s]?:\/\/)[^\/]+\/(.*?)\?"
Local $sString = "http://www.vkontakte.ru/lenitskyofficial" & @CRLF & _
"https://www.vkontakte.ru/lenitskyofficial" & @CRLF & _
"http://www.vk.com/lenitskyofficial" & @CRLF & _
"https://www.vk.com/lenitskyoffici_3al" & @CRLF & _
"https://www.vk.com/lenitskyofficial?qw=w123qwe"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")