re = /(http[s]?:\/\/)[^\/]+\/(.*?)\?/m
str = 'http://www.vkontakte.ru/lenitskyofficial
https://www.vkontakte.ru/lenitskyofficial
http://www.vk.com/lenitskyofficial
https://www.vk.com/lenitskyoffici_3al
https://www.vk.com/lenitskyofficial?qw=w123qwe'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end