package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(http[s]?:\/\/)[^\/]+\/(.*?)\?`)
var str = `http://www.vkontakte.ru/lenitskyofficial
https://www.vkontakte.ru/lenitskyofficial
http://www.vk.com/lenitskyofficial
https://www.vk.com/lenitskyoffici_3al
https://www.vk.com/lenitskyofficial?qw=w123qwe`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}