import Foundation
let pattern = #"(http[s]?:\/\/)[^\/]+\/(.*?)\?"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
http://www.vkontakte.ru/lenitskyofficial
https://www.vkontakte.ru/lenitskyofficial
http://www.vk.com/lenitskyofficial
https://www.vk.com/lenitskyoffici_3al
https://www.vk.com/lenitskyofficial?qw=w123qwe
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)