// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(http[s]?:\/\/)[^\/]+\/(.*?)\?").unwrap();
let string = "http://www.vkontakte.ru/lenitskyofficial
https://www.vkontakte.ru/lenitskyofficial
http://www.vk.com/lenitskyofficial
https://www.vk.com/lenitskyoffici_3al
https://www.vk.com/lenitskyofficial?qw=w123qwe";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}