#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:\bgoogle\.com$)|(?:\bgoogle\.com\.au$)|(\bgoogle\..*)"
Local $sString = "Should not match:" & @CRLF & _
"google.com.au" & @CRLF & _
"google.com" & @CRLF & _
"" & @CRLF & _
"Should match:" & @CRLF & _
"google.net" & @CRLF & _
"google.org" & @CRLF & _
"google.com.pk"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")