import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\bgoogle\\.com$)|(?:\\bgoogle\\.com\\.au$)|(\\bgoogle\\..*)";
final String string = "Should not match:\n"
+ "google.com.au\n"
+ "google.com\n\n"
+ "Should match:\n"
+ "google.net\n"
+ "google.org\n"
+ "google.com.pk";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}