re = /(?:\bgoogle\.com$)|(?:\bgoogle\.com\.au$)|(\bgoogle\..*)/m
str = 'Should not match:
google.com.au
google.com
Should match:
google.net
google.org
google.com.pk'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end