package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:\bgoogle\.com$)|(?:\bgoogle\.com\.au$)|(\bgoogle\..*)`)
var str = `Should not match:
google.com.au
google.com
Should match:
google.net
google.org
google.com.pk`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}